Back to overview
Resolved
Server Remake
Jun 27, 2026 at 12:08pm UTC
–
Jun 27, 2026 at 4:00pm UTC
Affected services
MC Server (mc.asteroide.cc)
Resolved
Jun 27, 2026 at 4:00pm UTC
Maintenance ended
Affected services
Created
Jun 27, 2026 at 12:08pm UTC
We're remaking Asteroide Anarchy. Removing illegals, resetting the world for the last time ever & fixing bugs
Affected services